Support » Generelt » Hyperlinks to PDF files not working

  • Hello

    My links suddenly stopped working. Both hyperlinks to pages and pdf’s etc.
    Then I tried to correct the permalinks in my wordpress settings. I chose something else, and then back to the origional. That helped on links to pages, but not on links to download pdf files.

    Please, I need help to make hyperlinks work when wants to download a file?

    Thanks in advance.

    /Sheila

    Siden, jeg har brug for hjælp til: [log ind for at se linket]

Viser 10 svar - 1 til 10 (af 10 i alt)
  • Dit link til siden kræver login, så det er ikke muligt at efterprøve.
    Ville gerne se navnet på de filer du ønsker at downloade.
    (har du brugt Æ Ø Å i filnavnet?)

    Har du flyttet til andet webhotel?
    Har du skiftet bogstavformat?

    Your link to the page requires login, so it is not possible to check.
    I would like to see the name of the files you want to download.
    (have you used Æ Ø Å in the file name?)

    Have you moved to another web hotel?
    Have you changed the letter format?

    Thread Starter sheilanana

    (@sheilanana)

    Hej Mikael

    Nej, der er ikke brugt Æ, Ø eller Å i filnavnet. Den seneste jeg har forsøgt, hedder “http://www.telman.dk/wp-content/uploads/2022/09/Uge-39.pdf”.

    Jeg har hverken skiftet til andet webhotel eller bogstavformat. Desværre.

    Jeg vil meget gerne give dig adgang til sitet, men har ikke lyst til at poste det her. Jeg kan også lave et midlertidigt login, hvis du sender mig din mail?

    Tak på forhånd.
    /Sheila

    Thread Starter sheilanana

    (@sheilanana)

    Jeg mistænker, at det har noget med min .htaccess fil at gøre, da mit wehotel sagde at den var blevet pillet ved. Hvortil links efterfølgende ikke virkede. Så forsøgte jeg at redigere i wordpress panelet, permalink. Hvortil siderne virkede igen, men ikke links til filer.
    Jeg ved ikke hvordan jeg igen tilpasser filen.

    Har du prøvet at hente og åbne din .httaccess ?
    (kan hentes med et FTP program og åbnes med et redigerings program, for eksempel Filefilla og Notepad++ -søg på nettet)

    Nogle af dine plugins har måske skrevet noget i filen. Det er ret nemt at identificere.

    Jeg har en gang haft problemer med .httaccess fordi en sikkerheds plugin havde skrevet for mange regler ind.

    Når WP installeres fødes .httaccess kun med følgende:

    # BEGIN WordPress
    # Direktiverne (linjer) mellem 'BEGIN WordPress' og 'END WordPress' er
    # dynamisk genereret og bør kun ændres via WordPress-filtre.
    # Eventuelle ændringer i direktiverne mellem disse markører vil blive overskrevet.
    
    # END WordPress

    Et forsøg kunne være at gemme den gamle på din pc (backup) og oploade en ny uden andet indhold end det webhotellet forlanger og WPs indhold og se hvad der sker.

    Thread Starter sheilanana

    (@sheilanana)

    Jeg kan se filen inde på mit webhotel (Simply.com). Den ser således ud:

    # BEGIN WordPress
    # Direktiverne (linjer) mellem ‘BEGIN WordPress’ og ‘END WordPress’ er
    # dynamisk genereret og bør kun ændres via WordPress-filtre.
    # Eventuelle ændringer i direktiverne mellem disse markører vil blive overskrevet.
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteRule .* – [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    Det ligner, at der er et stykke, der er tilføjet?

    Thread Starter sheilanana

    (@sheilanana)

    Det ligner desuden, at der er 2 .httaccess filer, hvoraf den ene er tom:

    Hvis de ligger i samme mappe så prøv at slette den tomme…

    Thread Starter sheilanana

    (@sheilanana)

    Jeg kan se, at der også ligger 2 på nogle af mine subdomæner, hvor den ene slutter med underscore (_). Så “kan” den slettes?

    Gem kopi på din pc med dit FTP-program og prøv.
    Går det galt så kan du installere igen

    Thread Starter sheilanana

    (@sheilanana)

    Hej Mikael

    Jeg fandt en løsning på det. Kort fortalt, så skulle jeg geninstallere et SSL plugin.
    Tusind tak for din hjælp 🙂

Viser 10 svar - 1 til 10 (af 10 i alt)
  • You must be logged in to reply to this topic.